News for hackers. Stuff that matters.
Re:What Are RFCs? The Forgotten Blueprints of the Internet by ErikCorry on Sunday October 19, 2025 @12:02PM (#45635205)
Forgotten? No mention of why we should think they are forgotten outside the headline.
Re:What Are RFCs? The Forgotten Blueprints of the Internet by zaik on Sunday October 19, 2025 @12:32PM (#45635535)
Outside of my friend group, no one uses XMPP, the internet standard for chat, they only know about walled gardens and custom protocols by VC startups now :(
Re:What Are RFCs? The Forgotten Blueprints of the Internet by SunlitCat on Sunday October 19, 2025 @12:41PM (#45635590)
Since when became XMPP "the internet standard for chat"? What about IRC[0]? :(

[0]: RFCs 1459, 2810 - 2813, 7194.

Re:What Are RFCs? The Forgotten Blueprints of the Internet by MYEUHD on Sunday October 19, 2025 @01:03PM (#45635786)
Whatsapp, Zoom and Kik Messenger use XMPP under the hood.

Just because it's not well-known doesn't mean it's not widely used

Re:What Are RFCs? The Forgotten Blueprints of the Internet by betaby on Sunday October 19, 2025 @01:15PM (#45635898)
Whatsapp used XMPP many years ago, not today though.
Re:What Are RFCs? The Forgotten Blueprints of the Internet by alexchantavy on Sunday October 19, 2025 @01:34PM (#45636079)
I miss when Facebook Messenger let you connect to it with XMPP back in the day so you could have it together with your other msging services on Adium/Pidgin
Re:What Are RFCs? The Forgotten Blueprints of the Internet by loeg on Sunday October 19, 2025 @01:24PM (#45635984)
XMPP has nothing going for it.
Re:What Are RFCs? The Forgotten Blueprints of the Internet by lou1306 on Sunday October 19, 2025 @12:43PM (#45635616)
Come on, of course there will be some protocols that are more obscure than others, but the overall concept of RFCs is far from "forgotten".

Besides, a lot of these walled chat gardens roll their own XMPP/Jabber thingy behind the scenes.

Re:What Are RFCs? The Forgotten Blueprints of the Internet by 1970-01-01 on Sunday October 19, 2025 @12:37PM (#45635570)
Clickbait gonna bait.
Re:What Are RFCs? The Forgotten Blueprints of the Internet by ackreq on Sunday October 19, 2025 @12:40PM (#45635587)
Nowadays, my friend, people just copy, paste, or vibecode everything. If you (or anyone) think they’re not forgotten, you’re one of the few who still read and understand the RFCs. Said that in the post too.
Re:What Are RFCs? The Forgotten Blueprints of the Internet by Anon1096 on Sunday October 19, 2025 @01:04PM (#45635795)
The people building the infrastructure powering the internet at cloudflare, major cloud providers, isps, etc are all regularly reading and referencing RFCs (from experience). People who aren't reading them now weren't reading them in the past either, we don't need some RFC moral panic.
Re:What Are RFCs? The Forgotten Blueprints of the Internet by Demiurge on Sunday October 19, 2025 @01:28PM (#45636017)
I agree. RFCs have a niche use case, like a manual, or a glossary. They're there, if you need them, but few people are supposed to be implementing RFCs or internet from "blueprints" all the time.
Re:What Are RFCs? The Forgotten Blueprints of the Internet by onraglanroad on Sunday October 19, 2025 @03:18PM (#45637056)
I don't think they're that niche. If you want to know what an email address can contain or what a cname should be, just read the RFC.

They're surprisingly easy to read and I'd encourage any younger readers to have a look at ones that are appropriate to your field. You'll almost certainly learn something new and it's good to have a grasp of these fundamentals.

Re:What Are RFCs? The Forgotten Blueprints of the Internet by vlovich123 on Sunday October 19, 2025 @03:48PM (#45637326)
Which RFC? The challenge as with all technical specifications is that you have revisions over time and even some times get split up into multiple RFCs. And then as with all interoper issues, is the RFC that you implement the one that other systems you’re interacting with also implementing that RFC. And then even after all of that, you have implementation differences where even if you follow the RFC to the letter, other implementations either made intentional alternate legal choices or had bugs.

RFCs are generally easy to read but there’s a meaningful chasm between understanding the RFC and what actually gets implemented in practice.

Re:What Are RFCs? The Forgotten Blueprints of the Internet by 1718627440 on Monday October 20, 2025 @03:46AM (#45640960)
Use a web search. And in a lot of RFC websites, you get cross-references if a document got superseded by another. Wikipedia also tells you that.
Re:What Are RFCs? The Forgotten Blueprints of the Internet by woodruffw on Sunday October 19, 2025 @12:57PM (#45635731)
I don’t know what niche you inhabit, but anecdotally the overwhelming majority of engineers I know have consulted an RFC. RFCs are an active component in the Internet; you need to at least reference them (if not fully read them) to understand how various parts of the Internet interoperate.

(It seems extremely unlikely that the average non-junior engineer hasn’t opened up RFC 3339 or one of the HTTP caching RFCs, just for example.)

Re:What Are RFCs? The Forgotten Blueprints of the Internet by dehugger on Sunday October 19, 2025 @01:35PM (#45636085)
I dunno, I think many dev are aware of the existence of RFCs, but if your work occurs at higher levels of the stack there is frequently not a pressing need to read them.

For example, you don't have to read the specific RFC to know the difference between 200, 400, and 500 status codes. Any layman's blog post (or literally just reading the response messages accompanying those codes in actual use) is enough knowledge to get you real far.

That said; if a senior dev isn't aware of 3339, the holiest of RFCs, then that's a problem.

Re:What Are RFCs? The Forgotten Blueprints of the Internet by Uehreka on Sunday October 19, 2025 @03:00PM (#45636915)
> That said; if a senior dev isn't aware of 3339, the holiest of RFCs, then that's a problem.

I’d love to read it, but I don’t have the time.

Re:What Are RFCs? The Forgotten Blueprints of the Internet by rkomorn on Sunday October 19, 2025 @01:58PM (#45636326)
There's a strong inverse correlation in my career between how often a dev refers to RFCs by number alone and how much I ever want to interact (let alone work) with them again.

Doubly so for the "meta" RFCs (eg 1925).

Re:What Are RFCs? The Forgotten Blueprints of the Internet by woodruffw on Sunday October 19, 2025 @02:20PM (#45636545)
I understand that PKI engineers are not a very fun lot, but it seems unfair to blame them for having the various X.509 RFCs beaten into them :-)
Re:What Are RFCs? The Forgotten Blueprints of the Internet by rkomorn on Monday October 20, 2025 @02:57AM (#45640721)
I think it's more a correlation than a causation, and I think it's the other way around.

It's not "I tend to not want to work with people who name-drop RFCs", it's "people I don't want to work with tend to name-drop RFCs".

And PKI engineers are cool (and a lot smarter than me).

Re:What Are RFCs? The Forgotten Blueprints of the Internet by ellenhp on Sunday October 19, 2025 @02:17PM (#45636522)
Would you mind elaborating on why you believe people need to have that number memorized to deserve the title senior?
Re:What Are RFCs? The Forgotten Blueprints of the Internet by worik on Sunday October 19, 2025 @02:33PM (#45636679)
Not the number
Re:What Are RFCs? The Forgotten Blueprints of the Internet by dehugger on Sunday October 19, 2025 @11:42PM (#45640027)
RFC 3339 describes how to record time in a consistent and interopable manner, expanding onto ISO 8601.
Re:What Are RFCs? The Forgotten Blueprints of the Internet by ellenhp on Monday October 20, 2025 @01:28AM (#45640360)
Thanks for the summary of the document, but not quite what I asked for. Why would e.g. a VHDL engineer need to have read it to deserve the title senior?
Re:What Are RFCs? The Forgotten Blueprints of the Internet by dehugger on Monday October 20, 2025 @12:50PM (#45646079)
Well you are kinda straw manning me, considering my own words were "that's a problem" and not "don't deserve a title senior engineer". I also specifically said "senior dev" and not "senior engineer", which are very different things. Maybe re-read the comment chain with fresh eyes, since you seem to have taken a very antagonistic interpretation?

I think most people here can agree that seniors should be aware of standards for recording time. If you know you should write a date as "yyyy-MM-dd hh:mm:ss" (add precision or timezone information as required) then congratulations you are aware of the necessary standards.

Re:What Are RFCs? The Forgotten Blueprints of the Internet by LambdaComplex on Sunday October 19, 2025 @01:20PM (#45635942)
Personally, I have about a dozen related RFCs on my bookmarks toolbar due to a project that I worked on. I was referencing them constantly when I was actively working on that project.
Re:What Are RFCs? The Forgotten Blueprints of the Internet by necovek on Sunday October 19, 2025 @02:10PM (#45636456)
I always thought RFC 2324 was more of an obligatory reading material.
Re:What Are RFCs? The Forgotten Blueprints of the Internet by alterom on Sunday October 19, 2025 @04:00PM (#45637434)
I'd say the same of RFC 1149¹

____

¹https://datatracker.ietf.org/doc/html/rfc1149

Re:What Are RFCs? The Forgotten Blueprints of the Internet by alterom on Sunday October 19, 2025 @12:49PM (#45635668)
Yeah, as if reading and understanding RFCs was the pastime of the commoner in Ye Olde Dayse.

Or as if the vibe-coder of today would've totally™ definitely© be the type of person to peruse the RFCs.

It's like saying the the proof of, say, Seifert-van Kampen theorem is "forgotten" because nowadays, my friend, people ask ChatGPT to write out solutions to their math homework.

Re:What Are RFCs? The Forgotten Blueprints of the Internet by James_K on Sunday October 19, 2025 @01:04PM (#45635793)
The fact that you are able to send this message over the internet is proof that a quite large population of people are still reading and still understand internet standards.
Re:What Are RFCs? The Forgotten Blueprints of the Internet by RHSeeger on Sunday October 19, 2025 @01:58PM (#45636334)
As part of my normal work, I linked and quoted part of an RFC just this week. They're not forgotten, just... less remembered, I guess.
Re:What Are RFCs? The Forgotten Blueprints of the Internet by candiddevmike on Sunday October 19, 2025 @02:24PM (#45636583)
Most things are now vendor proprietary and not designed for interoperability. RFCs are forgotten because you can't monetize an RFC.
Re:What Are RFCs? The Forgotten Blueprints of the Internet by woodruffw on Sunday October 19, 2025 @03:56PM (#45637394)
This is a very funny thing to assert on a forum that's entirely delivered via openly standardized (via IETF, W3C, etc.) technologies!

(Also, you certainly can monetize an RFC. In fact, that's the norm in a lot of RFC categories: the various PKCS-derived RFCs are a direct extension of various patented standards that RSA[1] sold software atop of.)

[1]: https://en.wikipedia.org/wiki/RSA_Security

Re:What Are RFCs? The Forgotten Blueprints of the Internet by lexszero_ on Sunday October 19, 2025 @03:04PM (#45636954)
Interestingly, ISO standard documents are sold for a non-insignificant price and DRMed, while people writing them are volunteers and/or paid by their employers to participate in standardization committees. A company willing to build equipment for an industry running on ISO/IEC communication protocols (like electric power distribution) may have to pay thousands for relevant standards, or rely on someone's interpretation of said standards to implement the protocol before they even begin, not considering certification costs.