An open protocol is a prerequisite. There's a 2018 IETF proposal for interoperable E2E messaging, initiated by Cisco, Google, Facebook and Wire:
Architecture: https://datatracker.ietf.org/doc/draft-omara-mls-architectur...
Protocol: https://datatracker.ietf.org/doc/draft-barnes-mls-protocol/?...
"Messaging Layer Security (MLS) ... is not intended as a full instant messaging protocol but rather is intended to be embedded in a concrete protocol such as XMPP [RFC3920]. In addition, it does not specify a complete wire encoding, but rather a set of abstract data structures which can then be mapped onto a variety of concrete encodings, such as TLS [I-D.ietf-tls-tls13], CBOR [RFC7049], and JSON [RFC7159]. Implementations which adopt compatible encodings should be able to have some degree of interoperability at the message level, though they may have incompatible identity/authentication infrastructures."
Already, in the starting point draft, it's been crudded up: it has "ciphersuites", and comes with support for the NIST P-256 curve --- despite the fact that the underlying design wants to take byte strings to curve points, which is tricky to do on the P-curve. It will only get worse from here. They'll figure out some reason to bolt a PAKE onto it soon enough.
Signal Protocol is exceedingly well-documented (and even before those documents were written, it was open enough for Wire to lift the protocol wholesale).
The IETF is bad at cryptography. Your default position should be distrust of IETF crypto standards.
(I like my source on this, but can't share it; I expect to be able to this year, though. In the meantime:
0e49002152a374d9c11251cf856a7ccf25ef9bd0db54c3e97bef2a4109dad4f0)
2. Facebook's interests in the standard are not necessarily what drives the standard; Facebook can just be along for the ride.
I think what's going to happen with this is what happens to all de novo IETF designs other than TLS, the one that the market requires actually work: it's going to fail. That's also the outcome that I'm hoping for.
In the meantime, if Millican wants to get together with Katriel Cohn-Gordon and do a Facebook-only ART protocol design for Facebook Messenger, with an eye towards replacing Signal Protocol in WhatsApp, that would be a great development. So would a Cisco-only ART messenger, or maybe even a Mozilla ART messenger (though Mozilla's motives are the ones I trust least here).
What does not make sense is for a protocol whose service model we barely understand even in theory to be designed from scratch in an open standards group. The IETF motto used to be "loose consensus and working code". Now it's "take an RWC paper, add the P-curves to it, and use it to fuck over the most successful secure messaging protocol".
We shouldn't be cheerleading this. It's capture, not progress.
This would be ideal. Until then I still feel Signal gives me the best balance and I haven't had too much issue with friend/family adoption.
Edit: To perhaps stem the downvote tide: The impulse for my comment is that OP probably hasn't tried it, even though Telegram and KakaoTalk have similarly sized userbases and the emotion-inspiring stuff in the Telegram client app is mostly a timid knock-off of better Asian messengers (the Telegram team faces the challenging task of slowly acclimatizing Western audiences to features it knows will eventually be popular, by example). The West-centricness of such statements is grating to me.
The reason my comment doesn't substantiate the UX difference further is that I can't think of a single feature or screen that isn't better realized in Kakao's Android app than in Telegram's. General performance, group management, galleries / archive retrieval stuff, cross sharing, search, stickers, etc. It's available with a full English UI, go have a look. (From a privacy/security/freedom POV Kakao is terrible, though.)
The only way I could see this happening is some open/decentralized chat protocol takes hold and private companies build nice UX on top of that.
Sadly, strong UX is not the strength of opensource/foundation driven development. (For the love of god someone please prove me wrong on this)
Even worse, one can only participate in their network with a mobile phone number. In my country, land line numbers do not even work.
To my mind Mozilla should have had, and kept, a set: Firefox, Thunderbird, instant messaging, Persona. Not forgetting Lightning etc.
But you can link the content, no? (example: https://t.me/dailyeng/1402). You see the full post, you don't have to donwload Telegram for this.
But you're right. I'll edit above.
I would donate some money for such an initiative if it also had strong privacy protections from the start.
Edit:// Evil might is the wrong word. But if you have the choice between a self enforced world police with a history of using information against people in foreign countries and a country that is mostly involved in their own shit and area the choice is IMO easy
https://en.wikipedia.org/wiki/Russian_military_intervention_...
https://en.wikipedia.org/wiki/Russo-Georgian_War
By using telegram you are directly supporting the Kremlin.
Not that i think any of both is right. But only one directly changes _my_ life.
See, for me it makes sense to link Telegram to Kremlin, as it's very obviously ran by Putins buddies.
If Signal devs are in a similar situation, it's certainly not nearly as obvious as with Telegram.
Do you have any reason to believe this, other than the guy's nationality?
Durov was the founder of VK (Russia's version of Facebook). He was approached by the Krelim and "forced" to sell his stake (nice social network you have there, it would be a shame if something happened to it)
https://www.theverge.com/2014/1/31/5363990/how-putins-cronie...
I would imagine if there's someone who hates the Kremlin, it's Durov.
So I'll ask again, do you have any evidence to support your claim? Because if it all hinges on his nationality you're sounding a bit biggoted.
lol.
>Do you have any reason to believe this, other than the guy's nationality?
It seems bigoted to assume that his nationality would have anything to do with this.
Durovs have spent years cultivating this lie of them having been forced to "exile" from Russia, despite being a regular sight in Saint Petersburg.
Pavel even went as far as assaulting someone and taking their phone after he was spotted in a local mall. https://lenta.ru/news/2017/03/20/durov/
>https://www.theverge.com/2014/1/31/5363990/how-putins-cronie...
>I would imagine if there's someone who hates the Kremlin, it's Durov.
Well then you probably wouldn't imagine that Telegram is being developed in the VKontakte HQ building, but nonetheless that is the case.
https://tjournal.ru/52954-durov-back-in-ussr
Maybe Durovs genuinely do hate the Kremlin, maybe not. It doesn't make a difference. They've spent years cultivating their false image as dissidents while remaining extremely close to Putin, whether or not they do so by choice makes little difference.
Essentially:
> By using Facebook/Whatsapp you are directly supporting the U.S.
is just as valid isnt it? Because you know Zuck has been to the White House and has followed requests by U.S. gov agencies.
Thats my whole point. If you have to choose between 2 evils, you choose that that is less threatening to yourself.
PS: I dont compare with Signal as they have neither spread nor common features.
Pavel literally fled the country and bought himself a different citizenship only to be best Putin buddy, yeah.
Telegram gets a lot of hate on HN, but I have to say that of all large messaging apps Telegram has by far the best UX. That said, I can see it slowly turning into a walled garden. For example, in public channels (distinct from groups, they're broadcast only) it should be possible to link to their content from the outside. Instead if you try that they force you to download the app to see the content. EDIT2: As someone noted you can link each individual post on a channel, but you can't see and scroll through a list of posts as you can from inside the app.
I wish we had a messaging app with a market as large as WhatsApp's, UX as good as Telegram, security as good as Signal, run by an organization like Mozilla.