News for hackers. Stuff that matters.
Re:A map of the entire internet as of May 1973 by lordnacho on Monday December 12, 2016 @09:20AM (#13158140)
Which modern protocols even existed back then? IP? TCP? FTP?
Re:A map of the entire internet as of May 1973 by DonHopkins on Monday December 12, 2016 @11:07AM (#13159039)
NCP, the Network Control Program, was the predecessor of TCP/IP. [1]

Host addresses were only 8 bits (zero was reserved), so there could only be up to 255 hosts on the ARPANET.

NCP was a simplex protocol, not full duplex like TCP/IP, so each port=>port connection transmitted data in only one direction, and applications would use an even/odd pair of ports for two-way communication.

The parity of the ports at each end of the connection was required to be different: you couldn't connect an even port to another even port, or an odd port to another odd port. "Homosocketuality" was strictly forbidden by internet protocols! NCP's mandatory "heterosocketuality" was called the "Anita Bryant feature". [2]

[1] https://en.wikipedia.org/wiki/Network_Control_Program

[2] https://news.ycombinator.com/item?id=12422813

Re:A map of the entire internet as of May 1973 by saghm on Tuesday December 13, 2016 @12:37AM (#13164746)
> The parity of the ports at each end of the connection was required to be different: you couldn't connect an even port to another even port, or an odd port to another odd port. "Homosocketuality" was strictly forbidden by internet protocols! NCP's mandatory "heterosocketuality" was called the "Anita Bryant feature". [2] > ... > [2] https://news.ycombinator.com/item?id=12422813

Well, that's a whole distasteful part of computer history I was blissfully unaware of before now. As someone fairly young (in my early 20s), it's sometimes hard to remember that things like this are very recent history, so I guess it helps to have some perspective every now and then.

Re:A map of the entire internet as of May 1973 by jslabovitz on Monday December 12, 2016 @11:20AM (#13159176)
TCP/IP wasn't the official transport protocol until 1983. Before that was NCP (https://en.wikipedia.org/wiki/Network_Control_Program). I got on the ARPAnet in 1982, and remember the transition day.

FTP and Telnet were around by 1974. So was an early mail protocol (described in RFC 524, https://www.rfc-editor.org/rfc/rfc524.txt) which used FTP as mail transfer agent. The first SMTP-like mail protocol was probably MTP in 1980 (RFC 722, https://www.rfc-editor.org/rfc/rfc772.txt).

Go read some RFCs -- they're great sources of early Internet history! Start here: http://www.rfc-editor.org/rfc-index.html

Re:A map of the entire internet as of May 1973 by IncRnd on Monday December 12, 2016 @09:40AM (#13158276)
FTP 1971, RFC 114

TCP & IP, 1974, A Protocol for Packet Network Intercommunication, https://web.archive.org/web/20160304150203/http://ece.ut.ac....

Re:A map of the entire internet as of May 1973 by amelius on Monday December 12, 2016 @10:10AM (#13158543)
What protocol did they used on the lowest level. E.g., what modulation scheme did they use? Did it run over the phone network? Or did they have their own cables?
Re:A map of the entire internet as of May 1973 by rootbear on Monday December 12, 2016 @02:55PM (#13161328)
As noted in other replies, the ARPANET predates IP and TCP. Although some Internet applications, like Telnet and FTP, were first implemented on the ARPANET, I don't consider it to be the Internet in any meaningful way. The Internet was conceived as a network of networks, which directly affected the design of TCP/IP. Thus, the Internet proper began with the transition to IP. ARPANET was a test bed, to see if packet switched networking would actually work. It did. So well, in fact, that the ARPANET was used for actual work, until it became obvious that something better was needed to replace it. That replacement is the modern Internet.

I enjoyed this book about the development of the ARPANET: https://www.amazon.com/Where-Wizards-Stay-Up-Late/dp/0684832...