News for hackers. Stuff that matters.
Re:A POI Database in One Line by qwertox on Friday April 19, 2024 @03:39PM (#40091144)
`python3 -m pip install -U overturemaps` (as specified in the README) -> "ERROR: No matching distribution found for overturemaps"

> ERROR: Ignored the following versions that require a different python version: 0.1.0 Requires-Python <4.0,>=3.11; 0.2.0 Requires-Python <4.0,>=3.11; 0.3.0 Requires-Python <4.0,>=3.11

> ERROR: Could not find a version that satisfies the requirement overturemaps (from versions: none)

> ERROR: No matching distribution found for overturemaps

So the new 0.3.0 requires at least Python 3.11, which seems excessively high, probably expecting the use of Conda (PackagesNotFoundError) or Nix (No packages found).

Re:A POI Database in One Line by cl3misch on Friday April 19, 2024 @04:29PM (#40091588)
Or simply not Ubuntu 22.04? You could also install new Python via conda, then overturemaps with pip.
Re:A POI Database in One Line by jwass on Friday April 19, 2024 @05:03PM (#40091867)
Just updated to min Python version 3.8. We didn't actually intend for folks to use it just yet but it's simple enough.
Re:A POI Database in One Line by qwertox on Friday April 19, 2024 @06:25PM (#40092599)
Thank you.