Re:Enabling IPv6 support for IPv4-only apps on Linux
by usr1106 on Wednesday October 04, 2023 @03:56AM
(#37762174)
What address syntax is that? I mean I can easily guess what it means, but I wasn't aware such mixture exists. Do connect(2) and friends support that?
[ Parent
| on HN ]
Re:Enabling IPv6 support for IPv4-only apps on Linux
by chungy on Wednesday October 04, 2023 @04:09AM
(#37762264)
It's an IPv4-mapped IPv6 address. Just interpret the IPv4 address like it's the last 32 bits of the v6 address.
In the example, 64:ff9b::103:307 is equivalent. A more complicated example might be akin to 64:ff9b::198.51.100.231, equivalent to 64:ff9b::c633:64e7.
Re:Enabling IPv6 support for IPv4-only apps on Linux
by g232089 on Wednesday October 04, 2023 @04:06AM
(#37762240)
It's an RFC6052 address.
Re:Enabling IPv6 support for IPv4-only apps on Linux
by usr1106 on Wednesday October 04, 2023 @04:27AM
(#37762410)
Thanks for the pointer. Actually RFC6052 just refers to RFC4291 from 2006 in this case. And that simply calls it an alternative representation.
Edit: RFC1884 from 1995 already had it, nothing has changed in that aspect.
Re:Enabling IPv6 support for IPv4-only apps on Linux
by pavel_odintsov on Wednesday October 04, 2023 @01:27PM
(#37768600)
Thank you very much for this question. I've rewrote and improve my article to cover exactly this topic: https://pavel.network/building-gateway-to-access-legacy-ipv4...