News for hackers. Stuff that matters.
Re:The modern HTTPS world has no place for old web servers by AndyMcConachie on Wednesday May 13, 2020 @10:13AM (#23167062)
What you're talking about is DANE.

RFC 6698

https://en.wikipedia.org/wiki/DNS-based_Authentication_of_Na...

I wrote a short explanation of how it works a while back.

https://www.metafarce.com/adventures-in-dane.html

The short answer is that DANE has been seeing deployment success for SMTP, but has yet to see much deployment success for HTTPS.

https://stats.dnssec-tools.org/

Re:The modern HTTPS world has no place for old web servers by AndyMcConachie on Wednesday May 13, 2020 @10:19AM (#23167115)
I'm one of the few weirdos that actually validates DANE for HTTPS using some software I wrote called Danish.

Once in Python

https://github.com/smutt/danish

And again in Rust.

https://github.com/smutt/danish-rust

An old explanation can be found here.

https://www.middlebox-dane.org/

Both middlebox-dane.org and metafarce.com have DNS TLSA records that match their certificate from Let's Encrypt. You can do this, but almost no one is.

There is some pickup in The Netherlands where I live. For example, www.digid.nl has delpoyed DANE for HTTPS.

Re:The modern HTTPS world has no place for old web servers by jlgaddis on Thursday May 14, 2020 @03:32AM (#23176537)
> ... DANE has been seeing deployment success for SMTP, ...

Since "DANE for e-mail" is still relatively new / obscure, for the uninitiated, RFC7672 [0] describes "SMTP Security via Opportunistic DNS-Based Authentication of Named Entities (DANE) Transport Layer Security (TLS)", which requires DNSSEC -- and, as a result, comes with all of its associated disadvantages / trade-offs.

An alternative, more recent method of providing authenticated and encrypted delivery of e-mail is described in RFC8461 [1], "SMTP MTA Strict Transport Security (MTA-STS)", which uses DNS and HTTPS -- and, thus, relies on CAs / PKIX. MTA-STS doesn't require DNSSEC but it is then susceptible to "malicious downgrades".

Although we're not going to see all e-mail being encrypted in transit anytime soon (if we ever do), it's good to know that there are folks working on solutions, including at some of the largest e-mail providers.

---

[0]: https://tools.ietf.org/html/rfc7672

[1]: https://tools.ietf.org/html/rfc8461

Re:The modern HTTPS world has no place for old web servers by tptacek on Friday May 15, 2020 @02:20AM (#23189466)
MTA-STS doesn't so much "not require" DNSSEC so much as explicitly work around ever needing it; that's stated as one of the goals of the protocol in the RFC.