News for hackers. Stuff that matters.

promiseofbeans

Not sure about this. See Firefox’s internal stats: https://data.firefox.com/dashboard/user-activity
Re:Beer CSS – Build material design in record time on Saturday June 27, 2026 @07:44AM (#48697403)
And worth noting that this mostly implements the newer version of material design (M3). However, M3 was a lot more focused on shapes besides just circles and rectangles, but they don’t seem to have quite gotten that here
Re:Printing Gaussian Splats on Tuesday June 23, 2026 @11:35PM (#48654782)
Looks like it. Plus it looks like they’re closer to a traditional screen sprinting shop in that they just take a file and will work with you manually tweak and adjust things to look good, rather than just printing a file straight away
How is your PDF coverage? They are notoriously difficult things to render, with endless edge cases. Mozilla’s PSD.js is the status quo here, so what do you do better than them?
Re:Gov.uk has replaced Stripe with Dutch provider Adyen on Saturday June 06, 2026 @07:47AM (#48424001)
Quite to the contrary: all a company is (at least as originally conceptualised) is the formalisation of a group of people, usually working together towards a shared goal. It’s in the name - just like you have a troupe of actors, you may have a company of engineers and accountants (though to keep in the vein of live stage production, you also have a theatre company).

This is why we tend to use collective pronouns when referring to a company - Meta just announced that they are planing share dilution (though to weaken my own case, one can also use singular nouns, likely due to the increased modern perception of a company as a single entity due to the increased anonymity afforded by the internet)

Re:Garnix (A Nix CI) is shutting down on Thursday May 28, 2026 @08:56PM (#48317638)
Luckily they seem to have open-sourced it [0], so it should still be able to serve this use case, and help others develop in the future.

[0]: https://github.com/garnix-io/garnix-ci

Re:Using Kagi Search with Low Vision on Thursday May 21, 2026 @08:30PM (#48230493)
It should also work with the Cloudflare privacy pass extension [0] FWIW, since Kagi just implemented RFC 9576 [1]

[0]: https://blog.cloudflare.com/privacy-pass-standard/

[1]: https://www.rfc-editor.org/rfc/rfc9576

Re:Reimagining the mouse pointer for the AI era on Tuesday May 12, 2026 @09:28PM (#48116774)
Their video demo is interesting. If that was to be useful, it would need to work on sites like Netflix. And for that to work, they would presumably have to axe drm. I am fully in favour of removing the pointless energy tax we pay as a society for the highly flawed and ineffective system of video drm.

Unless of course, their AI gets the same special privileges as the gpu in accessing drm content, and everything else is still locked out.

Re:NZ Government to Disestablish the BSA on Wednesday May 06, 2026 @07:37AM (#48035035)
It is useless policy season. This is highly unlikely to get through before the upcoming election. The press releases are mostly just virtue signalling.
Re:NZ Government to Disestablish the BSA on Wednesday May 06, 2026 @07:35AM (#48035025)
I’m highly doubtful about this - it seems to be an excuse to disestablish the BSA, rather than a genuine basis for the decision.

I think this will help drive more partisan and sensationalist media, like one gets in the US. NZ has been relatively resistant to populism and partisanism in the past, partially because we have a watchdog to make the media all play nice.

Based on their arguments, they should really be expanding the BSA’s remit to officially cover internet-based NZ media.

Also, they’ve done a press release and talked on the radio about it to try and stir up headlines, but it’s highly unlikely to get through parliament before the upcoming election. Based on the current polling, the makeup of parliament is likely to dramatically alter by the end of the year: https://en.wikipedia.org/wiki/Opinion_polling_for_the_2026_N...

Here in NZ, a lot of people live with less than 1GB of mobile data / month. Once you run out, you have to pay per MB at extortionate rates.

Most people still use sms rather than RCS or Signal or anything secure so they don’t have to pay for the data (most plans have unlimited SMS now)

Of course, the whole country has ultra-fast fibre on unmetered connections (even on the very cheapest plans), so if you’re at work or home it’s fine. Just using data on the go is a non-starter for many

Had lots of fun when this first came out - it just goes to an LLM. Lots of fun with nayan cat and other things.

The listed languages have extra prompts attached to them though

Re:Arm's Cortex X925: Reaching Desktop Performance on Tuesday March 03, 2026 @06:30AM (#47230938)
I mean… Apple went out of their way to build a GUI OS picker that supports custom names and icons into their boot loader.

So they don’t actively help (or event make it easy by providing clear docs), but they do still do enough to enable really motivated people

Re:Apple Introduces iPhone 17e on Tuesday March 03, 2026 @05:37AM (#47230592)
Using the iOS 26 keyboard on an iPhone SE 2/3 is a truly miserable experience now. Upgrading from 18 was a terrible mistake
Re:A Deep Dive into Apple's .car File Format on Tuesday February 17, 2026 @03:53AM (#47045181)
This is cool work. However, the author claims the following:

> This knowledge could be useful for security research and building developer tools that does not rely on Xcode or Apple’s proprietary tools.

Yes it could be. But if you developed it for such altruistic purposes, why tease the code?

> I’m considering open-sourcing these tools, but no promises yet!

Maybe OOP is thinking of selling their reverse engineering tools? Seems like that’s still a proprietary tool, I’m just paying someone else for it

Re:Sandboxels on Tuesday February 10, 2026 @03:43AM (#46956924)
Lots of fun references here - the Minecraft world border, and green goo looking “strange matter” from Kurzgesagt
LiDAR is the technology used to do spatial capture. The output is just point clouds of surfaces. So they’re generating surface point clouds from video
Re:The Book of PF, 4th edition on Sunday February 01, 2026 @05:15AM (#46845030)
Was thinking I had missed an entire edition of Pathfinder for a moment upon reading the title
Re:Apple Platform Security (Jan 2026) [pdf] on Saturday January 31, 2026 @02:43PM (#46840036)
They made C memory safe? This is a big thing to gloss over in a single paragraph. Does anyone have extra details on this?

> On devices with iOS 14 and iPadOS 14 or later, Apple modified the C compiler toolchain used to build the iBoot bootloader to improve its security. The modified toolchain implements code designed to prevent memory- and type-safety issues that are typically encountered in C programs. For example, it helps prevent most vulnerabilities in the following classes:

> • Buffer overflows, by ensuring that all pointers carry bounds information that’s verified when accessing memory

> • Heap exploitation, by separating heap data from its metadata and accurately detecting error conditions such as double free errors

> • Type confusion, by ensuring that all pointers carry runtime type information that’s verified during pointer cast operations

> • Type confusion caused by use after free errors, by segregating all dynamic memory allocations by static type

Re:The Cost of AI Art on Friday January 30, 2026 @08:58PM (#46832568)
I find it interesting how in the essay Sanderson implies he doesn’t take issue with AI as a tool. You can use it to search in a more advanced way, or to summarise meeting minutes.

He in essence claims there is some intangible attribute of a work that defines it as art or not depending on both the person who made it and the process they went through.

It does seem like a slightly romantic notion, since for any given item you can’t know if it’s art or not just by looking at it, which seems a bit odd. But then again, I suppose there’s a reason people pay for guided tours at museums so they can learn about the history and background of a work.

Side note: the title is editorialised; it should be “The Hidden Cost of AI Art: Brandon Sanderson's Keynote”

Re:HTTP Cats on Friday January 30, 2026 @06:27PM (#46831426)
I’ve used this site every time I’m doing http networking stuff for the past few years. It’s so easy to just go to http.cat/303 to check a status code you don’t know, or to scroll down the homepage to find the number you need for a specific response.

The cats make it much more fun than a regular docs page, whilst still being a useful quick reference. I wonder if other bits of reference information could be made more interesting in this way.

Re:New YC homepage on Saturday January 24, 2026 @12:09AM (#46741248)
The IEEE-reference feels like a cute nod to HN
Re:The Overcomplexity of the Shadcn Radio Button on Tuesday January 20, 2026 @04:01AM (#46689578)
In a hilarious turn of fate, on iOS safari the first time one of the radio options is clicked after loading, the css focus style is applied, but a click is not always registered so the radio item ends up stuck in an invalid weird-looking state. I highly doubt the issue would occur if the built in radio were being used
Re:Reticulum, a secure and anonymous mesh networking stack on Monday January 19, 2026 @11:11PM (#46687833)
> This repository is a public mirror. All development is happening elsewhere.

So if I have code on a personal (but publicly exposed) git server with a license that includes the above quoted terms, and someone decides they want to be helpful and publish a public read-only mirror of my code to GitHub, then they’re allowed to accept that license on my behalf? I never did a thing and yet I’m now in a contract with Microsoft? How does this work legally?

Re:Fix Your Robots.txt or Your Site Disappears from Google on Monday January 19, 2026 @02:46PM (#46683557)
Kagi has an optional AI summary users can trigger on demand, which feels a lot more useful than google’s - most of the time I want the actual websites, but sometimes I just want an overview of the top results which it’s really useful for
The vast majority of website-gate captchas are served by cloudflare these days. You can use the privacy pass [0] browser extension to skip them. Privacy passes are an open standard [1], so you can re-implement it yourself if you don’t trust that extension.

[0]: https://developers.cloudflare.com/waf/tools/privacy-pass/ [1]: RFC 9576 https://www.rfc-editor.org/rfc/rfc9576.html, RFC 9577 https://www.rfc-editor.org/rfc/rfc9577.html, RFC 9578 https://www.rfc-editor.org/rfc/rfc9578.html

Re:Cloudflare acquires Astro on Friday January 16, 2026 @04:36PM (#46652553)
I’ve been expecting this for a while - their last few releases have all had big features included for their cloudflare adapter
Re:I Accidentally Finished a Filesystem on Wednesday January 14, 2026 @05:21PM (#46624589)
All the commit messages read like they’re from an LLM as well
Re:I Accidentally Finished a Filesystem on Wednesday January 14, 2026 @05:17PM (#46624534)
For a comment that goes on about not being flashy, the writing tries it’s very best to be flashy

Older »