News for hackers. Stuff that matters.

andrius4669

Re:Intel QuickAssist Technology Zstandard Plugin for Zstandard on Wednesday August 16, 2023 @09:58PM (#37156230)
any idea how igzip's non-QAT path compares to zlib-ng[1]?

[1] https://github.com/zlib-ng/zlib-ng

Re:RNA repair mechanism discovered in humans on Saturday May 13, 2023 @08:44PM (#35934283)
immune system cells actually share a lot of the same receptor systems as neurons do, and these systems end up influencing each other to significant degree, both ways.

this rabbit hole goes deep...

Re:SQL: 2023 is finished: Here is what's new on Friday April 14, 2023 @09:43AM (#35569493)
NULL is more of a declaration that 'there is no value', than mathematical value on its own. if you compare NULL with something you don't get false, you get NULL (which is often considered same as false).

some implementations carry the same "uncomparable" logic when checking for unique constraints, while others drop the ball here.

programming language wise, it's kinda like null pointer or float NaN, both of which are also occasionally complained about, eg. indexing maps by float values can do bogus things in case of NaNs.

edit: clarified some things

I've been using it comfortably for years now, what do you mean?
Re:IPFS and Their Gateways on Thursday August 11, 2022 @10:20AM (#32426039)
Verification would require more data than CID itself provides (ipld document layout, chunking algorithm, max chunk sizes...).

See https://github.com/multiformats/cid/issues/22

>an upgraded and open SMS protocol that everyone can plug into

that exists, see https://en.wikipedia.org/wiki/Rich_Communication_Services

You definitely shouldn't strip left side of header, as space preceding that is syntax for header splitting over multiple lines at least in email. Not sure if this applies to http though, but some parsers may do that anyway, and some don't.

Just shows how easy it is to be wrong by being lazy with http parsing.

you can connect using bare IPs with http.
s/freenet/freenode/
It works pretty similar to cjdns, but implementation is not as crashy in my experience, also some transport protocol differences (ygg uses tcp while cjdns does udp), also DHT routing instead of cjdns supernode stuff.

So while usability is pretty similar, they're pretty different underneath.

Re:JPEG XL on Monday June 21, 2021 @06:31AM (#27577878)
firefox is chrome distribution? that's new to me
Re:JPEG XL on Monday June 21, 2021 @05:29AM (#27577599)
lossless reversible jpeg recompression seems to be a nod to the fact that jpegs aren't going anywhere.
Re:Git email flow vs. GitHub flow on Tuesday March 30, 2021 @07:49AM (#26633486)
>RFC 20452, RFC 20463, RFC 20474, RFC 20485

>RFC 68388

what are these numbers, I don't recall RFCs going into 5 digits yet

Link to relevant announcement email: https://lists.zx2c4.com/pipermail/wireguard/2021-March/00649...

There's also Jason's reply to apparently not-nice feedback of someone from NetGate: https://lists.zx2c4.com/pipermail/wireguard/2021-March/00649...

Re:JPEG – JPEG XL on Monday December 28, 2020 @03:50PM (#25563082)
http://sneyers.info/jxl/ contains some more information

they recently frozen bitstream: https://gitlab.com/wg1/jpeg-xl/-/tags/v0.2

Re:Libgen Storage Decentralization on IPFS on Wednesday November 25, 2020 @12:36PM (#25211825)
Does it actually work well? I tried to play with it a while back and while sharing files appeared to work, actually downloading them from other node didn't go that well..
Re:Nitrokey on Thursday August 27, 2020 @05:07PM (#24298672)
USB-C plug would still be complete and standard compliant USB (but not USB-A) plug.
Re:Is WebP really better than JPEG? on Thursday June 25, 2020 @05:14AM (#23638536)
>It's a shame it hasn't been adopted as a singular format yet

it has been. look up avif, you can already sorta try it out on firefox nighty.

Re:Is WebP really better than JPEG? on Tuesday June 23, 2020 @12:25PM (#23616143)
>hopefully some day it can be integrated into the standard.

see jpeg-xl

Re:FLIF – Free Lossless Image Format on Friday February 07, 2020 @07:14AM (#22265236)
yeah. it's partially based on https://github.com/cloudinary/fuif so if you use that part of JPEG XL you'll get something similar out of it.
Untrue in my experience.

Games still can render more FPS than mandated by vsync.

I tried playing sauerbraten (with SDL2) on sway other day, it was butter smooth (no tearing) with vsync off in game, and I felt no input lag unlike when I switch vsync flag on in game which limits FPS.

It probably does triple buffering, but somehow on sway it worked better than triple buffering of intel's xorg driver back when I tried that.

Re:Binance exchange hackers steal bitcoins worth $41m on Wednesday May 08, 2019 @08:45AM (#19858281)
>why continue to tolerate bitcoin?

you aren't obliged to use it, are you?

Older »