News for hackers. Stuff that matters.
Re:JQuery 2.0 Drops Support for IE6/7/8; API-Compatible with... by saurik on Friday June 29, 2012 @12:50AM (#4175303)
jQuery was never good at this. When I first used it on a project they had already drooped support for Safari 1.x, despite that being available version of Safari available for Mac OS X 10.4.

I was, at the time, living with my girlfriend and a friend of hers, both of whom used 10.4 and Safari 1.x: it was honestly quite common among people who couldn't quite afford new computers.

Regardless, when we sent the demo of our product for the local school district I was getting reports that the entire browser was crashing, which I traced down to some sketchy code in jQuery that had been tested so poorly on this version of Safari that no one noticed this highly fatal error.

When I reported the issue to a major jQuery contributor (a friend of mine), all I got was flak that people shouldn't be using that browser and should upgrade to 10.5... obviously I have never used jQuery in a project again.

Re:JQuery 2.0 Drops Support for IE6/7/8; API-Compatible with... by masklinn on Friday June 29, 2012 @02:09AM (#4175458)
> When I first used it on a project they had already drooped support for Safari 1.x

Which was a perfectly sensible decision from a developer POV considering how bad Safari's JS and DOM support was until 3.x

> despite that being available version of Safari available for Mac OS X 10.4.

10.4 was released with Safari 2.0 and got updates up to 4.1.3. Are you talking about 10.3?

Re:JQuery 2.0 Drops Support for IE6/7/8; API-Compatible with... by saurik on Monday July 02, 2012 @03:24AM (#4187751)
I simply cannot agree with you on this one; in my book, it is not in any way a perfectly sensible decision to make a browser that a ton of people were still using entirely crash when webpages using the library were opened.

The project I was working on was the kind of thing that probably had just a couple hundred people (if that, maybe even less) visit it during our testing period, and I got multiple reports of that crash.

If you want to popup a dialog box on these devices that says "I'm sorry, you are not supported" that's fine, but if it isn't even being on a browser like that, then no: it becomes entirely correct to point out that it was never actually good at handling cross-browser compatibility issues.

Re:JQuery 2.0 Drops Support for IE6/7/8; API-Compatible with... by yuhong on Friday June 29, 2012 @01:01AM (#4175330)
10.4 shipped with Safari 2.x and could be upgraded up to 4.x. You mean 10.3?
Re:JQuery 2.0 Drops Support for IE6/7/8; API-Compatible with... by saurik on Monday July 02, 2012 @03:18AM (#4187737)
I'll happily accept that (it was a while ago).
Re:JQuery 2.0 Drops Support for IE6/7/8; API-Compatible with... by kalininalex on Friday June 29, 2012 @11:55AM (#4177246)
What have you been using instead?