News for hackers. Stuff that matters.
Re:Reclaiming IPv4 Class E's 240.0.0.0/4 by ninkendo on Monday May 27, 2024 @08:58PM (#40496331)
I think you’re making my point for me quite nicely…

Originally it was “IPv6 is great, you don’t need dhcp”, but then it became “well you may need DHCP anyway so here’s DHCPv6”, and then that becomes necessary often enough that you can’t really point to that as a benefit of IPv6 any more.

You don’t need NAT but you need a lot of the systems complexity that NAT requires, because you have to manage two sets of addresses in various configurations. Split DNS, etc.

You’re fine if you own the address range and it isn’t provided to you dynamically with DHCP-PD, but that isn’t the case with basically 100% of residential deployments. You need to multihome to even apply as a RIR to get your own prefix.

Re:Reclaiming IPv4 Class E's 240.0.0.0/4 by ninkendo on Monday May 27, 2024 @09:19PM (#40496455)
Thinking aloud: there needs to be a rethinking of how prefixes work in the next ::/3 we allocate for global unicast: it should be possible for individuals to get their own /48 for basically the same price as a domain name today. Hell, they could make cash as people rush to buy the memorable ones. Make personal route announcement a basic part of ISP service as defined by the FCC. We’d have a fighting chance of actually having a decentralized internet again. But I’m basically wishing for a pony at this point.
Re:Reclaiming IPv4 Class E's 240.0.0.0/4 by icedchai on Monday May 27, 2024 @10:12PM (#40496728)
You can basically do this today. There are RIPE LIRs that will allocate you a /48 pretty cheaply. There are tunneling services that will route it to you.
Re:Reclaiming IPv4 Class E's 240.0.0.0/4 by sgjohnson on Monday May 27, 2024 @10:45PM (#40496871)
It’s not actually expensive or difficult for an individual to get an ASN and IPv6 space.

https://lagrange.cloud/products/lir £15 one-off for an ASN and £7/y for a /48.

Then you just need to find someone to give you a BGP session. https://bgp.services

Re:Reclaiming IPv4 Class E's 240.0.0.0/4 by ninkendo on Tuesday May 28, 2024 @09:26AM (#40500528)
I can't get any of that to my house. Comcast doesn't support BGP advertising a custom /48, and I can't even get one in the first place unless I'm dual-homed. The product you linked to has no details but it seems like you can get a /48 for their services, ie. if they're hosting my machines, they'll give me a /48. That doesn't help me.
Re:Reclaiming IPv4 Class E's 240.0.0.0/4 by icedchai on Tuesday May 28, 2024 @12:32PM (#40502553)
It helps you if you set up a tunnel back to your location. I have a /48 tunneled back to my home network over wireguard. There are several RIPE LIRs that will guide you through this, even if you're in the US. (You'll need a VPS in the EU to satisfy the contractual requirements. Your other VPSes can be closer to you.)
Re:Reclaiming IPv4 Class E's 240.0.0.0/4 by lmz on Tuesday May 28, 2024 @12:48PM (#40502726)
That 7£ /48 is a PA assignment, you can't take it home with you. https://en.m.wikipedia.org/wiki/Provider-aggregatable_addres...
Re:Reclaiming IPv4 Class E's 240.0.0.0/4 by icedchai on Tuesday May 28, 2024 @03:45PM (#40504797)
You can. I have some PA address space, assigned by an LIR, that I announce out of my own AS. All "PA" means is it comes out of their parent block and, if you stop paying, they'll probably want it back.
Re:Reclaiming IPv4 Class E's 240.0.0.0/4 by sgjohnson on Tuesday May 28, 2024 @04:59PM (#40505553)
Exactly. I have a PA /32 of IPv6 that I can sub-allocate and announce however I want. Or even lease to other people. It's my space, as long as I'm paying my LIR for it.
Re:Reclaiming IPv4 Class E's 240.0.0.0/4 by sgjohnson on Tuesday May 28, 2024 @04:58PM (#40505539)
You can do whatever you want with that PA assignment. PA means that it's the provider's address space, not yours. You can announce it wherever you want though.

The Wikipedia explanation is flat-out wrong.

Re:Reclaiming IPv4 Class E's 240.0.0.0/4 by lmz on Thursday May 30, 2024 @11:09PM (#40531114)
How would announcing it elsewhere help with the "Aggregatable" part? Are people accepting advertisements for small PA subnets?
Re:Reclaiming IPv4 Class E's 240.0.0.0/4 by sgjohnson on Saturday June 01, 2024 @01:26AM (#40543127)
Yes. A /48 of v6 is perfectly announcable.

There is no functional difference between PA and PI.

Re:Reclaiming IPv4 Class E's 240.0.0.0/4 by simoncion on Monday May 27, 2024 @10:28PM (#40496801)
> I think you’re making my point for me quite nicely

Sorry, what's your point? That having both address autoconfiguration and DHCP is too complex? If so, that's has been the standardized state of the art in IPv4 since 2005 with RFC 3927, and has been non-standard actual practice with Windows and Mac since like 1998.

> ...you need a lot of the systems complexity that NAT requires...

No, all you need is a router that can do IPv6. It doesn't even have to have a firewall, which is absolutely mandatory for consumer-grade border-router NAT.

> ...Split DNS...

I don't run that. My DNS answers local queries for LAN hostnames it knows about and forwards global queries upstream. Just like nearly every consumer edge-router DNS server.

> ...DHCP-PD...

Yep. My ISP runs that on the WAN side of the router. I just do RAs on the LAN side of the router.

Re:Reclaiming IPv4 Class E's 240.0.0.0/4 by tsimionescu on Tuesday May 28, 2024 @01:54AM (#40497748)
> Sorry, what's your point? That having both address autoconfiguration and DHCP is too complex? If so, that's has been the standardized state of the art in IPv4 since 2005 with RFC 3927, and has been non-standard actual practice with Windows and Mac since like 1998.

I don't think I've ever seen two computers communicate over a 169.254 address. Also, OS network stacks normally don't even try to get a link-local IPv4 address if they can get to a DHCP server or have a static address assigned. The RFC even recommends not using the link-local address if any other address is available. It's quite different from the way IPv6 works (as usual).

Re:Reclaiming IPv4 Class E's 240.0.0.0/4 by simoncion on Tuesday May 28, 2024 @02:13AM (#40497843)
> I don't think I've ever seen two computers communicate over a 169.254 address.

I have. Used to do it often in the dorms when the uni's DHCP server was on the fritz. Zeroconf/Avahi wasn't really a thing, so we'd use Network Neighborhood to get people's IP addresses to browse files or play on servers they were hosting or whatever. I have also (as the RFC envisions) done it when connected to ad-hoc WiFi networks, and also while directly connecting two Windows PCs. In those scenarios, I asked my peer what their IP address was, rather than bothering with going to Network Neighborhood.

> Also, OS network stacks normally don't even try to get a link-local IPv4 address if they can get to a DHCP server or have a static address assigned.

Correct. From the second paragraph of the Abstract of RFC 3927: [0]

> IPv4 Link-Local addresses are not suitable for communication with devices not directly connected to the same physical (or logical) link, and are only used where stable, routable addresses are not available (such as on ad hoc or isolated networks).

> The RFC even recommends not using the link-local address if any other address is available. It's quite different from the way IPv6 works (as usual).

No, it's also recommended when using IPv6 to not use link-local addresses if any other address is available. (Both because those addresses are only link-local, and because one usually needs to put an outbound interface specifier on the address when you go to contact another host, which is pretty obnoxious.) It just happens that IPv6's address autoconfiguration has been upgraded to be useful for globally-routable addressing, too.

So, yeah, a usual mode of both IPv4 and IPv6 networks is to have autoconfigured addresses, as well as DHCP-assigned addresses. It just so happens that most of the time IPv4 addresses are not autoconfigured, and most of the time IPv6 addresses are not assigned by DHCP.

That's equivalent complexity.

[0] <https://www.rfc-editor.org/rfc/rfc3927>

Re:Reclaiming IPv4 Class E's 240.0.0.0/4 by tsimionescu on Tuesday May 28, 2024 @05:49AM (#40499054)
> No, it's also recommended when using IPv6 to not use link-local addresses if any other address is available. (Both because those addresses are only link-local, and because one usually needs to put an outbound interface specifier on the address when you go to contact another host, which is pretty obnoxious.) It just happens that IPv6's address autoconfiguration has been upgraded to be useful for globally-routable addressing, too.

With what seems to be the recommended IPv6 setup at least for client machines, the Link-local address is the only stable identifier of that machine, as the actual reputable address changes all the time. So, the machine has both a link-local and a routable IPv6 at the same time, and both are going to be used. This is still different from IPv4, where link-local addresses are, again, an obscure feature that almost no one uses.

Re:Reclaiming IPv4 Class E's 240.0.0.0/4 by simoncion on Tuesday May 28, 2024 @07:38AM (#40499686)
> With what seems to be the recommended IPv6 setup at least for client machines, the Link-local address is the only stable identifier of that machine...

What? ULA space is the IPv6 equivalent of RFC 1918 space. If you want a prefix you know will not change, then you go generate you a /48 and use that on your internal network(s).

Why on earth would people expect ISPs that have a "We won't give you a guaranteed-static IPv4 address." policy to have a "We will give you a guaranteed-static IPv6 prefix" policy? Thinking that way is madness.

Perhaps you're confused because you're looking at guidance for client machines, when you should be looking at guidance for customer edge routers? Check out RFC 7084, and in particular section 3 and its subsections, and section 4.3 and its subsections. [0]

> ...as the actual reputable address changes all the time

Are you talking about IPv6 address randomization? (AKA "privacy" addresses?) IF you are, then know that it's

a) Controlled by the operator of the computer, rather than the operator of the network it's connected to.

b) Optional, and SHOULD be able to be turned off by the computer operator.

c) RECOMMENDED that a stable address be generated for the machine, in addition to the random ones.

Thing c) is in part to deal with "But what if I want to put a AAAA into the local DNS?" problem, and in part to give expected-to-be-long-lived connections an address that the system knows will hang around for at least as long as the interface is up.

After all, unless you want to tear down the connections associated with it, you can't remove an address from an interface until those connections have closed. More addresses allocated to a host means more multicast groups joined for that host, which eats up resources on the local networking infrastructure... so (if you're using "privacy" addresses) you really, really wanna steer ephemeral connections to addresses that are temporary, and long-lived ones to ones that are not.

[0] <https://datatracker.ietf.org/doc/html/rfc7084>

Re:Reclaiming IPv4 Class E's 240.0.0.0/4 by ninkendo on Tuesday May 28, 2024 @06:45AM (#40499336)
> Sorry, what's your point? That having both address autoconfiguration and DHCP is too complex?

My point is very simple: you can’t say “IPv6 is simpler because there’s no DHCP” if there’s DHCP. It’s pretty obvious right?

Re:Reclaiming IPv4 Class E's 240.0.0.0/4 by simoncion on Saturday June 01, 2024 @11:54AM (#40546769)
> My point is very simple: you can’t say “IPv6 is simpler because there’s no DHCP” if there’s DHCP.

DHCP is orthogonal to IPv6.

IPv6 deployment is simpler for many reasons. One being that at the typical end-user site you have neither v6 NAT nor v6 DHCP. Another being that you have enough address space (and we have collectively learned from the IPv4 allocation lessons how bad things can get) to have a good chance of setting things up so that routers need not do quite so much work to route v6 packets.