News for hackers. Stuff that matters.
Re:RFC-1149: IP over Avian Carriers by reaperducer on Wednesday June 05, 2019 @08:04PM (#20110303)
Another gem from back when the internet was fun:

HTTP Status 418: I'm a teapot - https://developer.mozilla.org/en-US/docs/Web/HTTP/Status/418

Wasn't there also a protocol for checking vending machines for cold drinks?

Re:RFC-1149: IP over Avian Carriers by sam_bristow on Wednesday June 05, 2019 @09:27PM (#20110749)
You're probably thinking of 'The "Only" Coke Machine on the Internet'

https://www.cs.cmu.edu/~coke/history_long.txt

Re:RFC-1149: IP over Avian Carriers by avianauthor on Thursday June 06, 2019 @07:44AM (#20113540)
I was at CMU '83 to '87. It saved us time to check if there was the proper kind of coke in the machine and if it was cold before we walked down to the room with the machine. It was cheaper than the University's vending machines. And it was in classy glass bottles.

Trivia: It was (I was told) using experimental 3Mbps Ethernet, the predecessor to the 10Mbps Ethernet that has grown to 10Gpbs+ now.

Re:RFC-1149: IP over Avian Carriers by ngcc_hk on Wednesday June 05, 2019 @10:05PM (#20110921)
I forward this discussion to my sons saying that there is a story about coke machine. Here you go. Thanks.
Re:RFC-1149: IP over Avian Carriers by FactolSarin on Wednesday June 05, 2019 @08:15PM (#20110358)
Considering we actually have internet connected teapots now, I wonder if any mass market products have implemented this.
Re:RFC-1149: IP over Avian Carriers by mrguyorama on Thursday June 06, 2019 @12:29PM (#20116121)
It's always been my dream to build one. Now that we have things like Raspberry Pi zero W, I want to hack up my Kuerig and make that internet connected
Re:RFC-1149: IP over Avian Carriers by ragebol on Thursday June 06, 2019 @03:07AM (#20112244)
IIRC Ultimaker 3D printers do implement this
Re:RFC-1149: IP over Avian Carriers by trp1 on Wednesday June 05, 2019 @08:23PM (#20110406)
Nope, they recently removed that status code.
Re:RFC-1149: IP over Avian Carriers by grkvlt on Wednesday June 05, 2019 @10:51PM (#20111169)
Only from clients supporting HTTP only. Note that RFC 2324 [0] defines the Hyper Text Coffee Pot Control Protocol or HTCPCP, which is an extension of HTTP and implementors of clients for this are free to return 418 if necessary. Also, RFC 7168 [1] which extends the protocol as HTCPCP-TEA now fully supports teapots, and is probably a better choice for modern clients. Also of interest is the SNMP MIB for remote management of 'Drip-Type Heated Beverage Hardware' which is defined in RFC 2325 [2] although this does not appear to have been updated with teapot, samovar, urn or other non-filter-coffee management data...

Implementing tea making device remote management would probably be a good candidate for a GSoC project or even a startup if you can find a VC gullible enough to fund you!

0. https://tools.ietf.org/rfc/rfc2324.txt

1. https://tools.ietf.org/rfc/rfc7168.txt

2. https://tools.ietf.org/rfc/rfc2325.txt

Re:RFC-1149: IP over Avian Carriers by furyofantares on Wednesday June 05, 2019 @08:29PM (#20110444)
From the spec. Teapots or any other devices are free to send it anyway
Re:RFC-1149: IP over Avian Carriers by nostrademons on Wednesday June 05, 2019 @08:52PM (#20110570)
Which is actually used in a few places. Google always return it from https://www.google.com/teapot, and Binance uses that status code if you've been IP-banned for exceeding rate limits.
Re:RFC-1149: IP over Avian Carriers by freedomben on Wednesday June 05, 2019 @09:48PM (#20110850)
I've worked on several big SaaS platforms, and all of them have at least one easter egg in there that returns teapot ;-)
Re:RFC-1149: IP over Avian Carriers by kbumsik on Thursday June 06, 2019 @12:58AM (#20111713)
Mandatory reading:

https://news.ycombinator.com/item?id=17175960

npm implemented it in their server last year!

Re:RFC-1149: IP over Avian Carriers by spondyl on Thursday June 06, 2019 @03:35AM (#20112351)
Our team got hit by that issue. I slapped by head when I saw the error code, having come across it before. How am I meant to debug something that's literally a joke and isn't meant to be used in production :(
Re:RFC-1149: IP over Avian Carriers by ngcc_hk on Wednesday June 05, 2019 @09:59PM (#20110895)
Yes.

Still remember the day 30+years ago using my 2400 baud to connect to internet and discovered FYI articles and the zen of internet.

Much better than reading ICL and IBM manual (red book ok but no fun) I supposed and debug 370 assembler Abend code etc.

Re:RFC-1149: IP over Avian Carriers by Papirola on Wednesday June 05, 2019 @08:06PM (#20110318)
finger
Re:RFC-1149: IP over Avian Carriers by ngcc_hk on Wednesday June 05, 2019 @10:18PM (#20110989)
I wonder if someone fill the column and it is not empty say 1 bottle left. Then it is still not cold if someone else got say the 2nd one. Any source code available to check :-)
Re:RFC-1149: IP over Avian Carriers by pklee on Wednesday June 05, 2019 @08:30PM (#20110450)
haha.. those were the days.. where you would get someone's resume over finger :)