News for hackers. Stuff that matters.
Re:Julia 1.0 by kwertzzz on Thursday August 09, 2018 @04:02PM (#17727973)
This is indeed a very good idea. In Julia, the package author defines the range of supported Julia version. Most package actually just say "version 0.6 or later". The JuliaDB package was just been updated preventing the installation on Julia 0.7 or 1.0:

https://github.com/JuliaComputing/JuliaDB.jl/commit/8bf3057d...

A automatic check as in R would indeed a better choice.

Re:Julia 1.0 by tavert on Thursday August 09, 2018 @04:41PM (#17728288)
That will only prevent installation of master of the package or the immediate next few versions on 0.7. The old package versions without a julia upper bound remain available so users on 0.7 or 1.0 will just be held back to old versions of JuliaDB until a new release without an upper bound gets made.