News for hackers. Stuff that matters.
Re:RFC 8314: Use of Transport Layer Security for Email Submi... by korethr on Wednesday January 31, 2018 @04:51PM (#16277857)
So reading this, this attempts to standardize what I understood to be best practice last time I ran a mail server - TLS required for submission and access. I see this as a good thing.

But this doesn't seem to touch on transmission between email servers at all, and that needs to be addressed as well. Email can be submitted protected by TLS, but if it has to cross the Internet in the clear to reach its recipient, then all you've succeeded in doing with submission/access TLS is prevented your user's login credentials from leaking. You've not done much to protect the confidentiality of your user's correspondence. Understand, I'm not denigrating the importance of TLS for submission and access, but it's also not the whole picture.

Yes, you can set your SMTP server to opportunistically use TLS when the other connecting SMTP server supports it as well, but not all SMTP servers do. Mandating TLS makes those servers that don't effectively unreachable. I seem to recall Facebook doing a study about it. The Postfix documentation warns about it as well.

I'm not sure I have a good solution here, other than something akin to the linked RFC: a proposed standard that gives a deprecation/sunset period to transition to mandatory TLS. The problem then, is getting majority compliance during that period. If the IPv6 transition is any indication, that's likely to be an uphill battle, as mandatory TLS between SMTP servers would break a rather large installed base that's presently working just fine.

Re:RFC 8314: Use of Transport Layer Security for Email Submi... by jlgaddis on Wednesday January 31, 2018 @06:19PM (#16278466)
> But this doesn't seem to touch on transmission between email servers at all, and that needs to be addressed as well.

No, this RFC doesn't address that -- as illustrated in the title ("...for Email Submission/Access").

As mentioned in section 1 ("Introduction") of the linked RFC:

  This memo does not address the use of TLS with
  SMTP for message relay (where Message Submission
  [RFC6409] does not apply).  Improving the use of
  TLS with SMTP for message relay requires a different
  approach.  One approach to address that topic is
  described in [RFC7672]; another is provided in
  [MTA-STS].
Note that "MTA-STS" ("MTA Strict Transport Security", similar to HSTS in function) is currently a draft. Feedback is solicited and very much welcome.

RFC6409: https://tools.ietf.org/html/rfc6409

RFC7672: https://tools.ietf.org/html/rfc7672

MTA-STS: https://tools.ietf.org/html/draft-ietf-uta-mta-sts-14

Re:RFC 8314: Use of Transport Layer Security for Email Submi... by khm on Wednesday January 31, 2018 @09:11PM (#16279241)
MTA-STS is pretty ill-conceived. In essence it mandates that compliant MTAs also run a concurrent web service. The authors do not explain why this is useful instead of the simpler approach -- enhance SMTP to reject mail on port 25 with a NEEDS-TLS error, then fall back to implicit TLS (what port 465 was originally for).
Re:RFC 8314: Use of Transport Layer Security for Email Submi... by noblethrasher on Thursday February 01, 2018 @01:53AM (#16280062)
The system needs to be able to authenticate a DNS-resolved endpoint. HTTPS provides this.

Of course, they could have gone with DNSSEC, but HTTPS has the virtue of solving the same problem (modulo proper configuration), while also being more widely deployed and better understood.

Re:RFC 8314: Use of Transport Layer Security for Email Submi... by khm on Thursday February 01, 2018 @02:41AM (#16280224)
HTTPS does not provide authentication sufficiently well to put every egg in its basket.

As for "better understood," the authors of this standard work for Google, Verizon, Microsoft, and Comcast. Combined they probably serve most of the email in the western hemisphere.

There is no excuse for overcomplicating a proposed standard -- and "we have this stuff lying around" is no exception. This plan has the effect of causing a networking protocol to depend on an entire series of unrelated networking protocols.

It does not bode well for the future of independent email operators and it provides no path forward for integrating existing devices. It pushes many, many extra steps onto client devices, necessitating entire additional libraries of software to deal with them. That's not a problem for companies with tens of thousands of developers at their beck and call -- but it is only going to raise the barrier-to-entry of operating an independent service.

Re:RFC 8314: Use of Transport Layer Security for Email Submi... by korethr on Thursday February 01, 2018 @01:50PM (#16284537)
Those sound like reasonable objections. Are you posting them to the discussions involved in shaping and ratifying the proposed standard?
Re:RFC 8314: Use of Transport Layer Security for Email Submi... by e12e on Thursday February 01, 2018 @08:38AM (#16281727)
What does https do that's different from verifying the cert chain and matching the cn to the hostname? Is this about the ill-conceived cert-pinning that pretends distributing keys for every domain is a scalable alternative to certificate authorities and on-line revocation lists?
Re:RFC 8314: Use of Transport Layer Security for Email Submi... by noblethrasher on Thursday February 01, 2018 @11:16AM (#16282985)
An MTA-STS web server is also used for policy discovery, and the HTTPS requirement ensures that the policy is authentic.
Re:RFC 8314: Use of Transport Layer Security for Email Submi... by 3pt14159 on Wednesday January 31, 2018 @05:32PM (#16278147)
The solution here is for Gmail and a few other large providers to announce a date where they will no longer send or accept email from insecure servers. This sounds drastic, but it's not. I've seen military contractors and patent attorneys sending email and attachments with no security at all. We need to stop pretending that security doesn't matter.
Re:RFC 8314: Use of Transport Layer Security for Email Submi... by bryankeithmoore on Wednesday January 31, 2018 @06:03PM (#16278365)
For the case of mail submission, there is a lot of legacy hardware/firmware out there still in use that simply doesn't support TLS, and is mission-critical, and is likely to become obsolete before anyone upgrades it. A lot of that traffic is considered nonsensitive by those who need it so trying to force them to be secure isn't going to go over well. Despite that, RFC 8314 recommends that MSPs deprecate cleartext submission and mail access, but it doesn't specify a timetable because the situations vary too widely from one provider to another.

For message relaying, your proposal might indeed work. The vast majority of inter-domain mail traffic goes through a very small number of providers. No mail provider can afford to not be able to exchange mail with gmail, or office365, or ...

Re:RFC 8314: Use of Transport Layer Security for Email Submi... by 3pt14159 on Wednesday January 31, 2018 @08:11PM (#16278999)
This type of thinking is how we get ants.

It is trivial to set up a mail server with TLS and if you don't have fucking TLS bounce it through a protocol upgrade server. If you understood the type of secrets that are getting trivially intercepted you'd realize that a couple hard days for a couple of lazy sys admins is a tiny price to pay for the drastic increase in security.

People are literally getting killed because we're so fucking lazy. Even three letter agencies are sending mail without TLS, this is madness.

Re:RFC 8314: Use of Transport Layer Security for Email Submi... by cortesoft on Thursday February 01, 2018 @12:40AM (#16279836)
What mission critical legacy hardware/firmware doesn't support TLS and is sending email to gmail?

Anyone running that mission critical hardware is free to keep using insecure email, no one is going to stop that. If they really need to send email from that old hardware to gmail, they can set up their own relay that accepts non-tls connections but relays using TLS.

Re:RFC 8314: Use of Transport Layer Security for Email Submi... by secabeen on Thursday February 01, 2018 @01:24AM (#16279946)
Nearly every printer/copier with a scan-to-email feature in a small-to-medium size business that has moved their all their servers and email into the cloud.
Re:RFC 8314: Use of Transport Layer Security for Email Submi... by randomString1 on Wednesday January 31, 2018 @11:20PM (#16279622)
Even if they define a 5 to 10 years warning before "deprecating" it is better than finding ourselves in the same hole the same amount of years from now.
Re:RFC 8314: Use of Transport Layer Security for Email Submi... by cornholio on Wednesday January 31, 2018 @07:05PM (#16278709)
It's drastic enough not to be realistic, it would break mail for too many people, who would blame it on Gmail.

What the big sites can do is add a delay when receiving from a plaintext relay, in a manner similar to greylisting and tarpiting that are widely deployed. The mail is not rejected, just delayed. The delay can be proportional to the amount of mail sent by a domain, and set to increase in time. The same can be done for outgoing mail to domains that don't advertise STARTTLS, drop the connection and retry later.

In the first phase, just issue a warning then drop the first submission attempt, to fillup the logs with a clear message that STARTTLS is strongly preferred. Gradually increase the delay so that large sites have trouble emptying their queue, and continue to increase the delay until the last holdouts can be simply shut out.

The advantage with this approach is that the user of Gmail, Yahoo etc. does not see a problem with his account, while the smaller sites and users will have delays when sending mail and receiving mail and be forced to take action.

Re:RFC 8314: Use of Transport Layer Security for Email Submi... by CapacitorSet on Wednesday January 31, 2018 @10:46PM (#16279510)
I'm pretty sure users would also blame delays on the receiving provider, not the sender (and they wouldn't be wrong, technically). I can picture a user saying "Oh, sometimes it takes ages for mail to arrive to my Gmail address, please send that document to username@<minor provider which doesn't delay mail>".
Re:RFC 8314: Use of Transport Layer Security for Email Submi... by cornholio on Thursday February 01, 2018 @06:53AM (#16281193)
The key here is to have an implementation schedule crafted so there is a massive differential impact on a selected group of small providers and a negligible impact on overall performance. After issuing warnings for a few months, put a cap on the number of plain-text submissions per domain, large enough to affect just the worldwide top 5-10 domains in that group. As more domains comply, roll that window, so as to keep just a very small fraction of total mail volume delayed, both incoming and outgoing. Since mail delays are common, the risk of switching by your own customers is low, and special exceptions can be made for accounts that communicate with an affected domain often.

It's essential that the major email domains work together so that the users of small non-encrypting domains feel a generalized performance impact, not just a problem with Gmail or just Yahoo.

Re:RFC 8314: Use of Transport Layer Security for Email Submi... by bryankeithmoore on Wednesday January 31, 2018 @05:01PM (#16277946)
See my reply below. My draft originally included the mail relaying case but trying to address both submission and relaying in the same document made the document unwieldy. In theory they both use the same protocol (more-or-less) but there are numerous subtle differences that make the two cases vastly different when negotiating encryption.

The IETF UTA working group has documents in process to address the mail relaying case; I'm sure they'd appreciate review and feedback.

Re:RFC 8314: Use of Transport Layer Security for Email Submi... by korethr on Wednesday January 31, 2018 @06:25PM (#16278504)
I believe I found them. I'll take a look and offer any comments I think are relevant.
Re:RFC 8314: Use of Transport Layer Security for Email Submi... by hannob on Wednesday January 31, 2018 @06:17PM (#16278449)
There's a draft to cover server to server: https://tools.ietf.org/html/draft-ietf-uta-mta-sts-14